Jaguar Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
161 Posts
Discussion Starter · #1 ·
I just discovered a leak from this connector, does anyone know the part number for this connector, it has UAYP D789 PPAC written on the side, but a google didn't bring anything up.

It's the connector with the metal clip that levers out and then pinch the tabs either side of the metal clip to release.

Anyone got any temporary fix ideas till I can get the part?

I
Jaw Gesture Style Automotive design Monochrome
 

·
Registered
Joined
·
4,317 Posts
Just the connector is not available, it's supplied as a pipe assembly, part number depending on VIN.
Font Parallel Rectangle Design Art
 

·
Registered
Joined
·
329 Posts
It's the connector with the metal clip that levers out and then pinch the tabs either side of the metal clip to release.
Unless it's different on the pre-facelift cars, I don't think that's correct, I recall two pipe had "wings" that had to be squeezed together and the other two if you pushed on the more or less rectangular metal area they unclipped easily without any prying out of the metal clip. (i.e. if they're the ones I'm thinking of the clip you have pried out is actually the release button ) Sometimes it helps to push the pipe down onto the fittings slightly before squeezing the clips/pushing the button too.
 

·
Registered
Joined
·
161 Posts
Discussion Starter · #5 ·
Unless it's different on the pre-facelift cars, I don't think that's correct, I recall two pipe had "wings" that had to be squeezed together and the other two if you pushed on the more or less rectangular metal area they unclipped easily without any prying out of the metal clip. (i.e. if they're the ones I'm thinking of the clip you have pried out is actually the release button ) Sometimes it helps to push the pipe down onto the fittings slightly before squeezing the clips/pushing the button too.
Could be right, I thought the metal clip stopped the wings being pushed together.

I got to thinking that there might be a blockage causing the leak as the the filter has been on for about 14000 miles without leaking. I plan to change the filter first as I had what I am assuming was blocked filter before (changing it resolved the issue) that had only done 18000 miles.
 

·
Registered
Joined
·
161 Posts
Discussion Starter · #6 ·
Changed the fuel filter and that seems to have resolved the issue. I am either getting poor quality filters (Bosch from ECP) or something is clogging them up.

The metal needs to be levered out for the wings to be pinched in, tried with the metal in place and they didn't move.
 
1 - 6 of 6 Posts
Top