Jaguar Forum banner

1 - 20 of 27 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi guys...2015 jag xf 2.2d, I'm getting a weird vibration noise under acceleration from the engine bay. Suspecting it could be a turbo issue. Video attached.
 

·
Moderator
Joined
·
19,578 Posts
No video attached fella.
 
  • Like
Reactions: DAVENN

·
Firm Rampant Member
Joined
·
15,608 Posts
only on acceleration or when idle too?
 

·
Registered
Joined
·
2,140 Posts
Got summat loose then.
 

·
Firm Rampant Member
Joined
·
15,608 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #6
Guys I'm struggling to upload the video...its not allowing me. Its only on hard acceleration, sounds like the airbox is open when I accelerate hard and only happens between 2 and 4000rpm. I've been advised that it could possibly be the turbo
 

·
Firm Rampant Member
Joined
·
15,608 Posts
Guys I'm struggling to upload the video...its not allowing me. Its only on hard acceleration, sounds like the airbox is open when I accelerate hard and only happens between 2 and 4000rpm. I've been advised that it could possibly be the turbo
split hose?
 

·
Registered
Joined
·
20,043 Posts
Guys I'm struggling to upload the video...its not allowing me. Its only on hard acceleration, sounds like the airbox is open when I accelerate hard and only happens between 2 and 4000rpm. I've been advised that it could possibly be the turbo
Vid needs to be uploaded to a hosting site such as YouTube first. Then post a link.

Sent from my SM-G977B using Tapatalk
 

·
Firm Rampant Member
Joined
·
15,608 Posts
a longer vid may help.


it then moves to a vid of a strumpet bouncing about ....
 

·
Registered
Joined
·
4,118 Posts
Sounds like induction roar/resonance to me. Almost as if the filter has been taken out, or something amiss with the air box side of things. It would explain why there's no fault codes too.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #13
Sounds like induction roar/resonance to me. Almost as if the filter has been taken out, or something amiss with the air box side of things. It would explain why there's no fault codes too.
Thanks...I will check it out
 

·
Administrator
Joined
·
28,949 Posts
I would have a close look for a split air hose, post turbo, that is opening up under boost pressure.
 

·
Registered
MY 2012 XF S Portfolio Ultimate Black
Joined
·
1,470 Posts
A longer video will help starting from lower rpms. However the turbo noises should have a higher pitch. Sounds more like an exhaust issue.
Does car go to RP or do you see any DTC?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #16
Thanks for your suggestions guys, though a longer video will be posted tomorrow, apologies for the delay
 

·
Moderator
Joined
·
19,578 Posts
There's definitely something going on when you hit the 2800rpm mark - which is when the 2nd turbo kicks in.

Is there not a valve for opening the airflow to the 2nd turbo, that could be starting to stick?
 

·
Registered
Joined
·
3,119 Posts
I would go with something related to the second turbocharger as well. Probably a long shot but you never know; I'd check and clean the MAF sensor for the secondary turbo first, it's pretty quick and easy to do (the primary turbo one will be accessible as well), there's a guide on this forum. Then check all the intake components from No.6 (MAF sensor) to No.19 and also No.17 etc.

Maybe worth checking for any codes with an appropriate reader (icarsoft etc).


185858


185859
 
  • Like
Reactions: OBC John
1 - 20 of 27 Posts
Top