Jaguar Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
3,151 Posts
Discussion Starter #1
I've come across a little issue with my number plate lamp holders.

I've lost the little metal clip which retains the unit in place and it's disappeared inside the silver trim bit. I did the same thing last time and really don't want to remove the trim again as it's a right PITA.

Has anyone converted them to a different type of holder, such as one with an LED PCB inside? I've used LED bulbs before and not had much luck.

Another issue also... I seem to have lost power to one of them (the reason I was taking it out in the first place).

I've tried a new bulb, but that's not working.

Looking at the wiring diagram, they appear to have their own separate feeds and a common ground. I'm guessing they have two feeds (for left and right) through the boot short loom connector? If so I'm guessing that's the likely culprit. I think I'll need to spend a bit of time with the meter.
 

·
Registered
Joined
·
208 Posts
Ah funny you should say this because I too "lost" the clip not once but twice. The saviour of the day was yet again my extendable magnet. Just simply inserted into the direction it must have sprung off and hey presto extracted it and there as ever was the missing spring clip.
The times that magnet has saved the day it ought to receive an award for its services to humanity. Okay perhaps a little ott but you get the gist. :)
 

·
Registered
Joined
·
198 Posts
I swapped mine for the LED units that replace the whole lamp. They are brighter and whiter but I think they look pretty good. They also seem to run cooler than the originals, which seemed to get pretty hot.
180834
 

·
Registered
Joined
·
6,104 Posts
I did similar on my X250 but the cheap units I bought interfered with the night vision on the rear camera.


Sent from my iPhone using Tapatalk
 

·
Super Moderator
Joined
·
26,654 Posts
I used ones similar to the ones Ant posted. Ford Focus figment I believe. Cheap and last a while.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
3,151 Posts
Discussion Starter #6
Done a bit of testing and poking around with the multimeter and it does appear that my boot loom is knackered.

Luckily it's only taken out one of the number plate bulbs, but might as well get it replaced.

Decided to go down the dealer route as I've heard of many issues from trying to source elsewhere.

I've also ordered a pair of new light units so hopefully we'll be back up and running before long.
 

·
Registered
Joined
·
3,151 Posts
Discussion Starter #7
Current dealer price for the short loom........

£96.68 with camera lead.

:LOL::oops:

I still think dealer route is the best option for this though.
 

·
Registered
Joined
·
3,151 Posts
Discussion Starter #9
Not sure the difference in price between the camera and none camera version but read an old post which said it was £86 odd back in 2015.... So doesn't sound too bad in that sense!
 

·
Registered
Joined
·
6,104 Posts

·
Registered
Joined
·
3,151 Posts
Discussion Starter #11
Interesting. I may query this with them then, but I suspect they'll just refer back to the Vin number and say that it's the correct part for my vehicle.

Anyone know if the length or connectors were changed at any point etc?

They've not quoted a part number itself, but I did make it clear that it was the boot short loom which runs through the rubber grommet between the boot lid and body, so I'd be very surprised if they've quoted for the wrong part.

There have been occasions before where physically identical parts have been given different part numbers and prices depending on which vin they've been assigned to though. A good example being the TPMS module. The "correct" one for mine was a hideous price, but the facelifted version was much cheaper and works just fine.
 
  • Like
Reactions: Statler

·
Registered
Joined
·
3,151 Posts
Discussion Starter #12
Hiya ****

I appreciate you have already ordered in this part, but would it be possible for you to give me the part number for this item?

I'm a member of a Jaguar forum (who have assisted with diagnosing this fault) and someone has given me a link to another authorised parts dealer with seemingly the correct part.
C2Z19978 | REAR TRUNK LID HARNESS LINK LEAD - JAGUAR XF 2009-2015 FROM (V) S61362 | Jaguar | | Britcar (UK) Ltd

I appreciate that you need to use the Vin number on your system to ensure you get the correct part for my particular vehicle but there seems to be a fairly substantial difference (less than half) in price for what appears to be the same part. I just wanted to make sure we hadn't got our wires crossed and the incorrect part has been ordered.

If it is the same part that's been ordered, why would there be such a large difference in price as surely they'd be a fairly standard fitment across all models of XF (other than the extra bit for the camera)?

Thanks in advance for any information you can offer me
I think that's fairly reasonable....

We will see what response I get!
 
  • Like
Reactions: Statler

·
Registered
Joined
·
3,151 Posts
Discussion Starter #13
Well I got a response and they've basically said the early ones had one different plug compared to later ones. Hence the difference in price.

Bit the bullet and bought it anyway.

Changed it over and all is good.

Here's the damage to the original.

180997


Could have probably got away with a repair short term but the rest would have gone eventually.

Interestingly, the date on the label on the old one was October 2011 so it must have been changed at some point after being built. It's not done too bad.
 
  • Like
Reactions: Statler
1 - 14 of 14 Posts
Top