Jaguar Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
Hi guys

Been having an issue with my car 2014 xfs ever since the intercooler went bang. It now has a new one fitted.

The issue is basically the car drivers perfect under half throttle, changes gear lovely as it should, if I go harder on the accelerator its starts to hold back and doesn't change gear as it should at the higher revs I'd say 3000rpm onwards. It actually started driving like that that after the intercooler initially went pop. I've never had any codes thrown up on the reader or restricted performance show up either.

Any ideas?

Cheers
 

·
Registered
Joined
·
19,092 Posts
Sounds as though there's still a leak. As it's a new intercooler then probably the connector in or out.

Sent from my SM-G977B using Tapatalk
 

·
Registered
Joined
·
533 Posts
The first thing I would check is the MAP sensor, very easy see forum. The inter-cooler probably went pop due to excessive pressure so be careful until you find the problem, or you may end up with split manifold. Check turbo bypass valve is working.As John say's above have a good check round for leaks.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #5
Sounds as though there's still a leak. As it's a new intercooler then probably the connector in or out.

Sent from my SM-G977B using Tapatalk
Hi and thanks. Have checked but cant see oe hear any leaks unfortunately .
 

·
Registered
Joined
·
31 Posts
Discussion Starter #6
The first thing I would check is the MAP sensor, very easy see forum. The inter-cooler probably went pop due to excessive pressure so be careful until you find the problem, or you may end up with split manifold. Check turbo bypass valve is working.As John say's above have a good check round for leaks.
Hi and thanks. I've checked both maf metres and both seem ok, it's just weird that even when the intercooler went pop , I wasnt getting any trouble codes or restricted performance showing I'm the dash, even though there was clearly and has restricted performance.
 

·
Registered
Joined
·
376 Posts
Hi and thanks. I've checked both maf metres and both seem ok, it's just weird that even when the intercooler went pop , I wasnt getting any trouble codes or restricted performance showing I'm the dash, even though there was clearly and has restricted performance.
MAP sensor was suggested not MAF.
MAP is in the top of the throttle housing
 

·
Registered
Joined
·
31 Posts
Discussion Starter #8
MAP sensor was suggested not MAF.
MAP is in the top of the throttle housing
Well that was a waste of time of taking them out hah. Dunno why I has MAF in my head. I'll pull that out tomorrow. Seems easy enough.

Cheers
 

·
Registered
Joined
·
31 Posts
Discussion Starter #9 (Edited)
Car is now sorted thanks guys. Imhad a quick look at the map sensor, was a little gunky but not blocked up at all. Gave it a little clean anyway, still was driving with limited power. Took it out for a run a couple of junctions and back on the motorway and kept it at 4000rpm the whole way and on the way back I could smell which I think was a regen? Anyway a minute later hey presto got full power back .

Cheers
 

·
Registered
Joined
·
31 Posts
Discussion Starter #10
A jaguar mechanic is saying that it's impossible that I could of forced a regen from driving like that? Either way its sorted.
 

·
Registered
Joined
·
533 Posts
Good news, lets hope it stays that way.
Regardless of what the problem was you know the MAF and MAP sensors are now clean which is a good bit of maintenance. If the engine management is not happy it will not REGEN so it still could be the MAP. When everything is working fine it may then REGEN.
Anyway well done!
 
1 - 11 of 11 Posts
Top