Jaguar Forum banner
61 - 80 of 110 Posts

Registered
馃彺鬆仹鬆仮鬆伋鬆仯鬆伌鬆伩X260 R-Sport in Aurora Red
Joined
11,809 Posts
Discussion Starter · #62 ·
Hi Gav, hope you鈥檙e well. Would you be willing to assist me with some coding? I鈥檓 trying to retrofit premium audio into my xf and not having much joy. More than happy to pay for your help. I鈥檓 only half an hour from where you are, so no problem travelling. All the best, Bryan.
Hi Bryan, sorry but I've no experience in doing this, I think posting a new thread and explain what you're trying to do and perhaps collectively we can help you.
Welcome BTW :D
 
  • Like
Reactions: ThxJag

Registered
Joined
7 Posts
Hi Bryan, sorry but I've no experience in doing this, I think posting a new thread and explain what you're trying to do and perhaps collectively we can help you.
Welcome BTW :D
Many thanks Gav, I鈥檒l post all the screen grabs, and what I鈥檝e done. I made changes to the ccf successfully, whether they are the correct changes I鈥檓 not certain, I was following Cambos thread. After fitting the premium cd/ headunit I get nothing on the touchscreen, the Amp I fitted via the MOST link appears on SDD as expected. Maybe the touchscreen needs a firmware change also or the headunit I got off eBay is faulty. 馃馃
 

Registered
Joined
394 Posts
Just used this guide and got lane keep assist and driver fatigue alert working. Thanks for your help so far on this, a good write up. There was some minor differences, but I guess that鈥檚 with MY of cars etc.

My next query: I want to update the modules on my car, is there a location in SDD that can do this? The telematics one especially takes an age to locate/communicate with the remote app. I know the latest is 19.2 which users on touch pro can easily see/update to, is it possible to update for cars with just the standard incontrol touch?
 
  • Like
Reactions: Gav

Registered
Joined
8,655 Posts
Well done!

There are no more updates for XF InControl Touch Chris, they stopped developing it a few years ago.
The latest maps are Q4 2018 which can be bought via the Jaguar InControl Map Updater app for 拢97.

I bought them a few weeks back through PayPal and the update wrecked my NAV card. I charged it back and Paypal have just refunded me.
I now need to go to a dealer and have the card replaced, which is likely to cost a few hundred pounds.

On the Remote App, what I would say is that my Remote App takes ages to respond as well, sometimes the car has started and the app is still trying. It'll even tell me the start failed, yet the car is running, so dont be too concerned.

If you want to investigate further, you can update modules through the Service Functions section of SDD. Make sure you have the backup Power Supply attached.
If you go to Selected Symptoms and choose and relevant area so that SDD brings up relevant fixes, so for Telematics choose :

Electrical > Information and Entertainment System > Telematics System > Telematics Services > Vehicle Not Reachable When Parked

Then click Continue, then click Recommendations at the top, you'll see the options

Telematics Control Module - Telematics Server Communication Check

Then if that doesn't pass you could try

Configure existing module > Telematic Control Unit Module

My guess, as I haven't done it, is that this will check that the existing module software is the most recent, and update if necessary.

There are quite a few other Telematics diagnostics as you scroll down.
Be careful what you do, let each test finish before trying something else

HTH
 
  • Like
Reactions: Chris JD

Registered
馃彺鬆仹鬆仮鬆伋鬆仯鬆伌鬆伩X260 R-Sport in Aurora Red
Joined
11,809 Posts
Discussion Starter · #68 · (Edited)
Just used this guide and got lane keep assist and driver fatigue alert working. Thanks for your help so far on this, a good write up. There was some minor differences, but I guess that鈥檚 with MY of cars etc.

My next query: I want to update the modules on my car, is there a location in SDD that can do this? The telematics one especially takes an age to locate/communicate with the remote app. I know the latest is 19.2 which users on touch pro can easily see/update to, is it possible to update for cars with just the standard incontrol touch?
Glad it helped and you've got what you want.
RE your next query I'd agree with Steve above, spot on.
When I used to to commute, it was a hit or miss, although you can see live status on the sim card connection is sdd somewhere I remember.
For me I got better results if I parked my car at the end of my drive, so took from that it was a weak signal, having said that I got the impression between rush hour it was a bit of hit or miss, jaguar servers getting overloaded?
 

Registered
Joined
394 Posts
Well done!

There are no more updates for XF InControl Touch Chris, they stopped developing it a few years ago.
The latest maps are Q4 2018 which can be bought via the Jaguar InControl Map Updater app for 拢97.

I bought them a few weeks back through PayPal and the update wrecked my NAV card. I charged it back and Paypal have just refunded me.
I now need to go to a dealer and have the card replaced, which is likely to cost a few hundred pounds.

On the Remote App, what I would say is that my Remote App takes ages to respond as well, sometimes the car has started and the app is still trying. It'll even tell me the start failed, yet the car is running, so dont be too concerned.

If you want to investigate further, you can update modules through the Service Functions section of SDD. Make sure you have the backup Power Supply attached.
If you go to Selected Symptoms and choose and relevant area so that SDD brings up relevant fixes, so for Telematics choose :

Electrical > Information and Entertainment System > Telematics System > Telematics Services > Vehicle Not Reachable When Parked

Then click Continue, then click Recommendations at the top, you'll see the options

Telematics Control Module - Telematics Server Communication Check

Then if that doesn't pass you could try

Configure existing module > Telematic Control Unit Module

My guess, as I haven't done it, is that this will check that the existing module software is the most recent, and update if necessary.

There are quite a few other Telematics diagnostics as you scroll down.
Be careful what you do, let each test finish before trying something else

HTH
Thanks, I鈥檒l give it a go. See what happens, reason I ask is I used to have an 18MY XE and the telematics on that performed well, no issues with the remote app at all, that did have touch pro though. This just seems to be so slow with responding every time I want to use it. Not sure if that鈥檚 due to model year change, firmware, or something else entirely.
I鈥檝e also seen there been mention of winter wiper mode on here, is this available on 17MY? I鈥檒l have a look for it if so as that could be useful.
 

Registered
馃彺鬆仹鬆仮鬆伋鬆仯鬆伌鬆伩X260 R-Sport in Aurora Red
Joined
11,809 Posts
Discussion Starter · #70 ·
Thanks, I鈥檒l give it a go. See what happens, reason I ask is I used to have an 18MY XE and the telematics on that performed well, no issues with the remote app at all, that did have touch pro though. This just seems to be so slow with responding every time I want to use it. Not sure if that鈥檚 due to model year change, firmware, or something else entirely.
I鈥檝e also seen there been mention of winter wiper mode on here, is this available on 17MY? I鈥檒l have a look for it if so as that could be useful.
RE Winter WM, I don't see why not it's just parking the wipers further up the screen
 
  • Like
Reactions: Chris JD

Registered
Joined
394 Posts
RE Winter WM, I don't see why not it's just parking the wipers further up the screen
I just got this activated, it鈥檚 called heated wiper park in the list. Took me a while to find it, change disabled to enabled, takes less than a minute and done. Option is now there to use.
 
  • Like
Reactions: Statler and Gav

Registered
馃彺鬆仹鬆仮鬆伋鬆仯鬆伌鬆伩X260 R-Sport in Aurora Red
Joined
11,809 Posts
Discussion Starter · #72 ·
I just got this activated, it鈥檚 called heated wiper park in the list. Took me a while to find it, change disabled to enabled, takes less than a minute and done. Option is now there to use.
Nice one Chris , that鈥檚 half the problem , deciphering the terminology and mapping this to what the sales blurb says
 
  • Like
Reactions: Chris JD

Registered
Joined
394 Posts
@Gav

I noticed you select diesel particulate service interval to enabled, just wandering what has this now given you?
 

Registered
馃彺鬆仹鬆仮鬆伋鬆仯鬆伌鬆伩X260 R-Sport in Aurora Red
Joined
11,809 Posts
Discussion Starter · #74 ·
@Gav

I noticed you select diesel particulate service interval to enabled, just wandering what has this now given you?
TBH nothing! I'm missing the DEF fluid level in the dash menu, and saw that so I enabled it without knowing what it'd do, haven't seen any difference!
 

Registered
Joined
394 Posts
TBH nothing! I'm missing the DEF fluid level in the dash menu, and saw that so I enabled it without knowing what it'd do, haven't seen any difference!
I have the def fluid level in the dash menu on my 17MY screen, it's within the same screen as miles to next service and shown in miles left. On 18MY+ cars this information is also shown on the remote climate app in the status menu.
 

Registered
馃彺鬆仹鬆仮鬆伋鬆仯鬆伌鬆伩X260 R-Sport in Aurora Red
Joined
11,809 Posts
Discussion Starter · #76 · (Edited)
I have the def fluid level in the dash menu on my 17MY screen, it's within the same screen as miles to next service and shown in miles left. On 18MY+ cars this information is also shown on the remote climate app in the status menu.
Yip, I only have mile to next service in that menu but should include the def fluid too :(
 

Registered
Joined
65 Posts
Hi Guys,
I have one question to the LKA.
When I only enable the LKA, update IPMA,... The LKA does recognize that i leave tha lane, but it doesn't steer back into lane. Only the Icon in the Gauge turns from the green lines to a red symbol.
187759


So I tried a few more things and ended up by this.
If I turn the power steering type from "eletric power steering without external angle and torque control" to "electric power steering with external angle and torque control" the LaneKeepAssist works perfect.
187760


but...
I have a parking assist in my F-Pace. I noticed, that this function doesnt work anymore. If i want to turn it on, the button only blinks for a while.
Because I can't have it when something doesnt work, I change the steering type back to "...without external..." and the parking assist works again.
So the final question is...
Do you also have a parking assist in your car? And if so, what kind of setting do you have in power steering type?
If I had to chose one, i would take the LKA but i cant imagine that these two options are mutually exclusive.


Thanks for help,
Tommy
 

Registered
馃彺鬆仹鬆仮鬆伋鬆仯鬆伌鬆伩X260 R-Sport in Aurora Red
Joined
11,809 Posts
Discussion Starter · #78 ·
Hi Tommy unfortunately I don't have park assist, but looked at adding it but looks like a dedicated bumper(s) for the additional sensors (which I could overcome) and wiring was missing :(
Might be worth PM @Onotole or @MoJo88 , I'm sure you'd be able to have both
 

Registered
Joined
6 Posts
My car is x260 with a stereo camera, but only AHB is activated by the manufacturer.
I am trying to activate LDW, LKA, TSR, Driver Impairment Monitor, and Emregansy braking. I activated the needed keys CCF editor, Reflashed Image Processing module, but be ably torn on in menu only LDW and its working partial (Showing just icon in dash).

Diagnostic is showing two problems
  1. IPMA U2300 Fault type 64 (Algorithm based failure - signal plausibility failure)
  2. IPMA U2300 Fault type 51 (System programming failure - not programmed)
Can someone help me?
 

Registered
馃彺鬆仹鬆仮鬆伋鬆仯鬆伌鬆伩X260 R-Sport in Aurora Red
Joined
11,809 Posts
Discussion Starter · #80 ·
Sounds like it hasn鈥檛 programmed the IMPA properly which sdd are you using and what cable?
do you get green ticks when sdd initially scans for modules?
 
61 - 80 of 110 Posts
Top