Jaguar Forum banner
261 - 280 of 298 Posts

·
Registered
🏴󠁧󠁢󠁳󠁣󠁴󠁿X260 R-Sport in Aurora Red
Joined
·
13,893 Posts
Discussion Starter · #261 ·
More than likely pin 13 is not connected in the new lead?
 

·
Registered
🏴󠁧󠁢󠁳󠁣󠁴󠁿X260 R-Sport in Aurora Red
Joined
·
13,893 Posts
Discussion Starter · #263 ·
You need to test with a continuity meter.
 
  • Like
Reactions: PetoP

·
Registered
XF Sportbrake MY 2013 3.0 DS
Joined
·
368 Posts
Indeed interesting, Peter.
Normally such adapter cables are wired 1:1. You could check it with a multimeter and a small piece of metal for the female connector. I use the pin of a LED for such small connectors. Should be thin enough for the female connector. I would check the cable befor using it for configuring the car.

If I got you right, the rain sensor is connected to the BCM/GWM module. In your screenshot GWM and BCM are shown as two different modules. I guess that's only software. I guess the functionality of the rain sensor is just configured by the CCF of the BCM (module). After checking the adapter cable you could just read the CCF from the BCM and search for the option of the rain sensor. Please take care that you only read it and don't write it back to the car. I think it was Download for car->laptop and Upload for laptop->car.

Dirk
 
  • Like
Reactions: PetoP

·
Registered
Joined
·
74 Posts
So I did measure the extension cable with multimeter. I used the beeping option for checking if the wire is cut. And I have to admit that I have apparetnly very bad luck... My extension cable was not beeping (so either wire is cut or there is some other component like condensator or diode that prevents direct continuity) for following pins...
8 3 1
9 11 12 13
 

·
Registered
Joined
·
11,216 Posts
.....
Please take care that you only read it and don't write it back to the car. I think it was Download for car->laptop and Upload for laptop->car.
It's the other way around Dirk. You download to the car.
It's somewhat logical as we 'download' from the internet to 'save' something so in theory the car downloads from the laptop to save the configuration.
 

·
Registered
XF Sportbrake MY 2013 3.0 DS
Joined
·
368 Posts
So I did measure the extension cable with multimeter. I used the beeping option for checking if the wire is cut. And I have to admit that I have apparetnly very bad luck... My extension cable was not beeping (so either wire is cut or there is some other component like condensator or diode that prevents direct continuity) for following pins...
8 3 1
9 11 12 13
That's curious, Peter. Your method is ok. But the result is not ok. Should have all a resistance of lower 0.x Ohm (= continuity).
Dirk
 

·
Registered
Joined
·
74 Posts
Now I have a question to SDD. How can I select which module I want to modify? I opened engineering mode, then I went to Recommended tab, clicked on Agree and a few times tick. But it has automatically selected Gateway module. I would like to see also others. Beside enabling of Light/Rain sensor that is currently on hold as I need to figure out how to pull out sill (but that is discussed in different thread), I would like to try to enable Jaguar App if possible as this functionality is not active in my Jag. Not sure if there is also possibility to enable Androind auto on normal InControl (probably not). I would like to enable lane assist (LKA) and traffic sign recognition. I have already lane warning. I have no clue if it is possible with my car but would like to try. Reading this thread I learnt that even if the feature is not fitted due to missing hardware it shouldn't harm entire car. It just sould do nothing. Hope my understanding is correct.
 

·
Registered
Joined
·
11,216 Posts
This is called SDD which means Symptom Driven Diagnostics. You need to tell the software that you have a certain problem e.g. rain sensor doesn't work.
It'll step you through a list of possible issues and point you at a resolution.

Try that first before doing any more and get a feel for how it works.
 

·
Registered
Joined
·
11,216 Posts
I don't know if it can do anything other than diagnose the AHU - Audio Head Unit
Usually the diagnosis ends up with an update to the module firmware.
I don't think you can update InControl this way.

I noticed last time I fired SDD up it wanted an update. I'll try and get my SDD laptop up and running again over the weekend.
 

·
Registered
Joined
·
74 Posts
@Gav can you please tell me what is meant by "stereo cameras"? is that the camera on the windshield that recognizes lanes or something else?
I have seen your comment at the 3rd page of this thread. so want to understand if I can enable all of these features. My car has vibrating lane control and don't have adaptive crusie controle.

what can be enabled with stereo cameras?
  • traffic sign recognition
  • intelligent cruise control and speed limiter (works with sign recognition)
  • intelligent emergency braking (pedestrians recognition)
  • lane keep assist
  • high beam assist
 

·
Registered
🏴󠁧󠁢󠁳󠁣󠁴󠁿X260 R-Sport in Aurora Red
Joined
·
13,893 Posts
Discussion Starter · #276 ·
@Gav can you please tell me what is meant by "stereo cameras"? is that the camera on the windshield that recognizes lanes or something else?
I have seen your comment at the 3rd page of this thread. so want to understand if I can enable all of these features. My car has vibrating lane control and don't have adaptive crusie controle.

what can be enabled with stereo cameras?
  • traffic sign recognition
  • intelligent cruise control and speed limiter (works with sign recognition)
  • intelligent emergency braking (pedestrians recognition)
  • lane keep assist
  • high beam assist
Hi Peter, see post #212 (How to add options to your car via ssd Part 1 of 2)
That's what Stereo cameras look like, if you have these then the above can be enabled.
 
  • Like
Reactions: Statler and PetoP

·
Registered
Joined
·
74 Posts
I did the setup but Traffic Sign Recognition and LKA Steering Assist is not working. When I tick it gets untick. I have also upgraded IPMA but no difference. Any idea what can be wrong?
These are the values I have set. I have also noticed that Tire Pressure sensors are not showing any value after the change.
Rectangle Font Parallel Screenshot Number
 

·
Registered
Joined
·
74 Posts
I tried many combinations off ccf configs but without a good result. With the current configuration, I am able to enable LDW tick, but it's only showing a red icon without vibration of steering well. When I am trying to set "Assistance" in LKA menu it's automatically changing to "Vibrating" but Vibrating is don't working.
My current configurations are

  • Lane Keep assist -> Fitted
  • Lane Departure warning -> Lane Departure warning with Trafic sign Recognition
  • Power Steering type -> Electrical power steering with angel and torque control
  • Inteligant speed limiter -> Fitted
  • Driver Asisst -> Fitted
I also tried without the last 2 changes, the result is the same.

Errors in my previous post automatically disappeared when I deleted all changes in CCF And left only these.
Hi @sargsarmen it seems I'm facing the same problem as you described. Did you manage to resolve it?
 
261 - 280 of 298 Posts
Top