Jaguar Forum banner
21 - 32 of 32 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #21 · (Edited)
Thanks for comments

I have tried dhalworths suggestion. It stalls after a few cycles of park/ reverse and footbake applied . If left in reverse and brake released it still stalls and there is a clacking noise from gearbox. Not the same quieter clack when park brake lock is released.

I know there is no sensors in torque convertor but suspect it might be at fault. I am prepared to replace he box but want to be more certain that is needed/ will fix the problem. The car has done 110k and fluid was black. Just want to get it fixed!

The battery is on charge then I will try SDD.. EDIT... generic lead did not work so JLR one from British diagnostics.
 

·
Registered
Joined
·
18 Posts
Hello

I am a New poster with my third jag

It is a 2014 3.0 diesel XF sport saloon.

Problem - stalls when moved from Park. I have searched on here and other forums.

Work done - lots on internet research including searching this forum
Codes read with generic reader.
Fuel filter replaced and EGR cleaned as research suggested these as possible "easy" fixes.

Gear box code - p1707-72 "transfer case neutral or Park/neutral indication circuit - actuator stuck open" this led to removing Transmission control module/ valve body (TCM). Testing solenoids for resistance indicated park one was high so all replaced. Problem remained.

ECU - Code U0167 - lost communication with immobilizer also read.

Second hand TCM purchased from established ebay seller with 100% + feedback - fitted. Problem remains. I swapped over the electronics from the old TCM as I knew it would otherwise need coding. I do not have SDS.

Also checked electricals including battery voltage.

Current codes are P2784-02 "input/turbine speed sensor A/B correlation" - this did not appear until TCM changed.
ECU codes U0167 still...and P0700 Transmission control system malfunction and U0402-54 invalid data TCM. I guess these are related to P2874-02.

Any suggestions please? I fear I am looking at a gear box change. Has anyone done this themselves? Where is the immobilzier on these? It starts fine so I struggle to see that being the problem.

Thanks very much
Have you tried a manual reset I found the procedure so not sure if it will work for your xf but might be worth a try.....
would like to share a guide "how to software reset automtic gearbox" guide.
please keep in mind:i am not responsible if damage your car
1. go in to the car.
2. WITHOUT foot on the BRAKE press the start button:
so the (ignitio is on) but (engine is off)
3. press and hold gas pedal down for 30 + second
4. take your foot off from gas pedal
5.press the start button to turn off ignition (let the car turn off completly before you start it again)
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #24 ·
Have you tried a manual reset I found the procedure so not sure if it will work for your xf but might be worth a try.....
would like to share a guide "how to software reset automtic gearbox" guide.
please keep in mind:i am not responsible if damage your car
1. go in to the car.
2. WITHOUT foot on the BRAKE press the start button:
so the (ignitio is on) but (engine is off)
3. press and hold gas pedal down for 30 + second
4. take your foot off from gas pedal
5.press the start button to turn off ignition (let the car turn off completly before you start it again)
From the many hours.. days .. spent on line re my box problem I don't think that resets the xf transmission. Currently I am awaiting lead to try SDD
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #28 ·
Sorry no update for a while, been awaiting SDD stuff then another gearbox.

Finally got SDD working a few days back and same codes so got another gearbox for expected./ feared replacement. First .. thought it worth swapping over valve body and electronics then programming (configure TCM) this to car. Managed to do this today but...
symptoms remain - car starts, but stalls when moved from drive into reverse.

Currently only possible relevant codes left are - B1B33-87 IPC target indication transfer and P0571-13 BCMB brake switch A circuit. There are a couple of other but SDD does not suggest them as issues and its main favourites with green % rating are gone with new valves and configure.

It has been a long day so will think again tomorrow but expect it may be torque convertor. Any other proceedures I need to do? . SDD will not perform the TCM diagnostic test - i get an error message. Some other test also highlighted that new TCM still had vin number of previous car - but did not suggest how to correct this.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #31 ·
Gearbox replaced. Still same problem - car starts but stalls when put into reverse from park.

SDD Codes are clear when car is just started (no attempt to shift from park ) but B1B33-87 target identification transfer and U0167-00 Lost communication with vehicle immobiliser control module are found when data collection re-run after a stall event. I am guessing that the immobiliser is somehow acting when I leave park but it re starts - no disconnecting battery etc.

Thanks in advance for any helpful suggestions
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #32 · (Edited)
Hello

I now have just B1B33-87 (Target identification transfer) which appears only after I try selecting reverse. Therefore seems relevant? It does not appear after a code clear until a stall/cutting out happens.

SDD suggests - Engine control module (ECM) fault. Instrument cluster (ICM)fault. CAN fault. Low battery voltage

SDD Fixes - check power and ground to ECM and ICM - where are the grounds for these please? I have found electrical manual and pictures but not found them easy to follow. There is only one earth (G1D124) behind my rhd front wheel but two in pictures- also a G1D108 which I have not found.

Other suggestions are - CAN network testing - so SDD network test and battery - both done/tested.

- CAN network check between ECM and ICM- anyone know how?
 
21 - 32 of 32 Posts
Top